Workflow Performance Issues

Incident Report for Drip

Resolved

The issue affecting workflow performance has been resolved. Normal operations have resumed. Please reach out to support@drip.com if you have any questions.
Posted Oct 21, 2025 - 21:04 CDT

Investigating

We’re currently investigating performance issues affecting workflows. Our team is actively working to identify the cause, and we’ll provide an update as soon as we have more information.
Posted Oct 21, 2025 - 20:38 CDT
This incident affected: Workflows and Rules.