Analytics Delayed

Incident Report for Drip

Resolved

This incident has been resolved. There was no data loss during this incident — all click activity has been recorded and reflected accurately. Thank you for your patience while we worked to restore full functionality.
Posted Oct 21, 2025 - 08:08 CDT

Identified

We’ve identified an issue affecting Analytics, which are currently failing to update in real time. All other analytics and services remain operational. There is no data loss — data is being captured as expected but is not yet reflected in reporting within the app. Our team is working to restore real-time updates as quickly as possible. We’ll provide another update once analytics are fully refreshed.
Posted Oct 20, 2025 - 17:44 CDT
This incident affected: Analytics.