App Performance Delays

Incident Report for Drip

Resolved

The earlier outage has now been resolved. Please reach out to support@drip.com if you see any lingering issues.
Posted Oct 20, 2025 - 06:03 CDT

Monitoring

We have identified and are currently monitoring a service disruption in our system due to an outage on AWS. We apologize for any inconvenience this may be causing and will update you as we continue to monitor the situation closely.
Posted Oct 20, 2025 - 04:48 CDT
This incident affected: REST and JavaScript APIs, User Interface, and Workflows and Rules.